ios7 compatible?

I just upgraded my iPhone4 to ios7 and now I’m having issues staying connected to it via wifi… seems to connect for a bit then disconnect, then connect and disconnect… is there a solution coming?

Hello,
Same problem here, same hardware. istop camera on iphone 4 with iOS7 and istopmotion for mac, both updated to the last available version. Both apps appear to connect to each other for a few seconds but I cant see any video live feed (I get a message stating that I have to authorize the connection or wait for autoconnect wich is already enabled). Afterwards, programs disconnect, then reconnect and so on.
It puts my wife’s pregnancy time-lapse in jeopardy so I might downgrade to iOS6 if a fix isn’t released. For now I would advise istop camera users on iphone 4 not to upgrade to iOS7 or at least to save their iOS6 SHSH with tinyumbrela in order to be able to downgrade if necessary.

Thank you for reporting this issue. We are able to reproduce the problem and we are currently working on a fix. Hopefully Apple will review the bug fix submission pretty quick. Sorry for any inconvenience!

Hi,

Same issue here.

In plus, thé iPhone can’t make good sharpness and good exposure. Is it an ios7 issue too ?

@Vince26: Please be patience and wait for the update of iStopCamera. It is already submitted to Apple for approval. Hopefully it gets released this week. Please can you update the app then and give us feedback if your issue still persist?

Just updated the iphone app. Seems to work perfectly. Thank you very much for the fix.

Even with the new version of iStopCamera (2.2.1) on my iPhone 4S, I do have same issues :

iStopMotion on iPad mini iOS7, and Camera Remote on iPhone 4S iOS7 :

With a wifi network made by Airport express, without internet connection :

  • on the iPhone it say (in french “Connexion Wifi nécessaire”) “Need wifi connection”. On the iPad, I don’t have possibility to select sharpness or exposure point. BUT I DISCOVERED that after taking one picture, and sometimes rotate the iphone 180° and then 180° again, the panel “Need wifi connection” disapear ! And I have possibility to control sharpness exposure and withe balance ! Just note the exposure and sharpness is not precise at all : it work one time on ten.
    Note that I don’t have to make exposure or sharpness directly on the iPhone.

With a normal wifi network with internet :

  • Here, I don’t have to do the trick to take a picture and turn 180° x2. And no panel “Need wifi connection”. Just the panel “waiting for connection” that deasapear when I choose the remote iPhone on the iPad or Macbookpro. It work perfect.
  • But I do have same difficulty to make sharpness and exposure. Almost impossible.
  • So, I’ve tried directly on the iPhone in Camera remote : same bug : very difficult to make sharpness. (note that I can try it on the iPhone Camera remote because of the normal wifi connection ; as I said above, with the network made by Airport Express without internet, I don’t have the possybility to make exposure sharpness or WB directly on the Camera remote)

So, I’ve finally tried to make sharpness and exposure directly on the iPhone in the Apple Camera app : it work perfectly in still picture mode AND in video mode. Is it because of new API of iOS7 that you don’t use for now ?

So… For now, I can’t use your solution. I’m force to use old DV camera in standard definition, through my MacBook Pro :((

Just one last bug : iStopMotion on the iPad (iOS7), even with the build in camera, have a strange bug : suddenly touching the “record” button to take picture doesn’t work at all. One time it work again after reliance iStopmotion ; another time, forcer to restart iPad. It a random bug.

Sorry but… Am I alone with those kind of bugs ? For all of you, it works well ? Perfect exposure and sharpness (like iOS7 photo app) ?

Perfect over wifi network ? Am I alone to use “without internet” wifi network ?

I have no news from support. Do they work on it ? Is there any page that list know bug ?

Have I bought iStopmotion for iPad and an airport express for nothing ? For now, I’m force to use an old standard definition camcorder in firewire with my MacBook Pro :confused:

Please…

@Vinc26: Sorry, I didn’t had the opportunity to test your setup yet. Currently we don’t have any support tickets with this kind of problem.

Even with the exposure and focus bug ? Can’t you reproduce that ? The big difference between doing exposure or sharpness in iStopMotion camera remote and the Apple Photo camera app ?

I was able test your setup (iPad, iPhone, AirPort Express disconnected from internet) and it worked quite well. The only thing I had trouble with was that I disabled the DHCP service in my AirPort Express and because of that the devices didn’t get an IP-Number and couldn’t talk to each other. After having set this up as well it worked like expected.

  • Is live view visible on your receiving iPad?
  • Do you see the red square boxes representing the focus point and brightness point?
  • Do those boxes move on both devices synchronously once your move them on on device?
  • The focus and exposure should adjust right after you release your finger. What happens when you do that?

Hi,

Thanks for the update 2.2.2 of camera remote.

  • Network bug : seems to be fixed !
  • Exposure and sharpness bug : not fixed :frowning: Exposure is almost ok. But it’s always impossible to make sharpness correctly. The “Camera” app from apple works perfectly, but not yours : Camera Remote (on my iPhone 4S, iOS7.0.3) always make sharpness on infinity. When I try to make it on object around 20cm, it try, but it can’t, and go back to infinity.
    Exactly the same situation in Apple Camera app, it works perfectly (and quickly) to make sharpness on 20cm.

Any help ?

Vincent :slight_smile:

I’ve tried differents configurations :

  • iStopMotion on iPad Mini non-retina iOS7.0.3 + iStopCamera on iPhone 4S : Sharpness and exposure doesn’t work well as I said before ; even if I try directly on the iPhone 4S screen.
  • iStopMotion on MacBookPro + iStopCamera on iPhone 4S : Yes ! It works ! Even if I use the iPhone 4S screen to point sharpness and exposure !
  • iStopMotion on MacBookPro + iStopCamera on iPad Mini : Yes ! It works too !

Conclusion : it seems that the problem is in iStopMotion on the iPad ?!

Waiting for some news,

Vincent.

We tested it again with different iPads, including an iPad Mini, all running the latest iOS and the latest App version for iStopMotion for iPad as well as iStopMotion Remote Camera, but we weren’t able to reproduce the issue you are describing. Did you try to restart your iPad Mini (switching it off by holding the switch-off-button for a couple of seconds)?

I’ve found something about this bug !!!

With iStopmotion on my MacBookPro :

  • If I work with a 720 project : it works (Focus and exposure)
  • If I work with a 1080 project : it doesn’t work too, like with iStopmotion on the iPad !

Is it the same thing with you ?

Vincent.

@Vinc26: We finally managed to reproduce the issue thanks to your findings! If you have an iPhone 5 (1st generation) running iOS 7 and using it to capture 1080p content (either with iStopMotion for Mac or iStopMotion for iPad), then the camera won’t perform the focus correctly. Because it only happens on this specific hardware we believe that it might be a bug in iOS but we are still investigating.

We use iOS 7 and an iPad mini (16GB) as remote camera. They don´t connect with an AdHoc Network. They do with our Wlan network, but it´s lame and we don´t want to use it.

Another question: Is there a zooming function for the ipad as remote camera? We can´t find.

Since the zoom in iOS is only a digital zoom that decreases the image quality, we decided not to add zooming capabilities.