Help with Keyboard Shortcuts?

Hello, I’m testing out mimoLive for our productions and liking what I see so far!

Question that I cannot figure out from the online instructions. When setting up a combination of layers to be activated by a keyboard shortcut (for quick switching during a live broadcast by a solo operator), I can see how to activate all the layers I want when I press the keyboard shortcut, however:

  1. When I press that keyboard shortcut a second time it does not select the specified layers. It seems to toggle some other combination which is working against the layer combination I want selected every time I press that keyboard shortcut. How to I get it to always select only the specified layers?

  2. When the keyboard shortcut activates the pre-selected/programmed layers, other layer that are already active remain live so the final shot is not what I selected with the combination of layers assigned to the specific keyboard shortcut. how do I get all layers not assigned to the keyboard shortcut to de-activate when I press a specific keyboard shortcut.

Thank you!

Hey Mate, when I started off with MIMO live, in the early days’ I had faced the same issues. Based on what I understand from your post I would advise you to,

  1. Toggle on and off the keyboard preset before going to the next preset. Eg, - if you have Ctrl+A for a particular set of layers, toggle it off the layers with Ctrl+A before going to the next preset.

  2. Also you could look into the how your layers are adjusted and arranged. Make sure the layer variants with different presets are not grouped together.

  3. Would highly recommend you use MIMO Remote and assign layer/layer variants to custom remote tabs. This makes live editing much easier.

@August what might be happening is some of your layers are not finished their activity before you turn them off. So for example, if you have a placer layer, and a lower third layer, and the lower third layer has a six-second action, if you turn them both on, and then 3s later, turn both off, the placer will turn off but the L3 will bug out.

Your best workaround is to use the remote control surface. You can create a button that explicitly turns some layers on and other layers off, without relying on the “toggle”.

Thank you, the excellent advice to us the iPad mimoRemote app solved everything noted above for me.

But it really seems the same capability of custom combo-layer scene buttons in the iPad remote app should be doable with programable keyboard keys on the computer software alone.

Not sure how mimoLive could even be useable without an iPad, though it works very well with one. Thank you!