Help - mimoLive Remote server fails to connect

Hi - I am using mimoLive 5.10 and the iOS remote app. I enable Remote Control Access in the preferences, and click “open in browser” and it works great, so far so good. But if I try with the iOS remote app from an iphone or ipad, it “sees” the mimoLive host computer, but when I click on it the screen goes black and it hangs with a progress wheel.

When I try opening the URL in an external browser, it fails to even see the mimoLive remote server. On closer inspection, the URLs mimoLive reports are confusing. Sometimes it gets the mycomputer.local:8989 address that you would expect; other times that URL is much longer (but it ends in my ISP The second URL is meant to be a local IP address but it is malformed - instead of 192.168.x.x:8989, I’m seeing But my whole network is addressed 192.168.x.x. And when I try from another computer on the network to access http://192.168.x.x:8989 it fails to connect completely. I have found no way to access the remote control except from the computer I am running mimoLive on. And just to double check I tried running a web server on port 80 and I can reach that with no problem from another device using the 192.168.x.x address.

Is there a way to fix this? Where does mimoLive find the IP address it suggests in the preferences? Is there something breaking down there? Why would it have a 173.158 address suggested rather than something actually on my network? I don’t have VPN enabled when I’m doing any of this. Any suggestions? Thank you!

Hi @bernardo.attias I’m sorry to hear about the troubles. From your description, I almost suspect that your network is preventing direct communications between devices and forces connections on non-standard ports to go through a proxy server, either for performance or for security reasons. What is strange is that the web server on port 80 is correctly reported. The local IP number reported by mimoLive is actually what macOS thinks your local IP number is. Have you tried using the 173… address manually from the iOS device or another computer?

Yes and as you would expect, nothing happens. It isn’t seen as a real address on the local network. Why would my network be doing this? I’m able to view other services on my local network (like the web server, or a plex installation, a photosync app, not to mention printers etc). I tried resetting my modem as well.

Where does mimoLive find what MacOS thinks my local ip number is? Every other app I use, and if I look in network settings, seems to know its 192 ip.

mimoLive simply does an API call to macOS to request the current IP number.

Can you open and run the “ifconfig” command. Does the 173… address show up anywhere there?

Another idea might be that macOS reports back an IPv6 address which mimoLive interprets incorrectly. But this would mean that there is no IPv4 address configured which is unlikely if the 192 addresses work. And the “mycomputer.local” should work in that case. Quite puzzling…

Hmm it’s not the same 173 address but when I typed ifconfig this was at the bottom of the list:

ipsec0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 50000
inet → netmask 0xffff0000

Meanwhile the ip that mimolive reports is

The ipsec0 interface points to the computer being connected to a VPN. It could be some security software that routes requests through a VPN to a server for virus scanning or something like that. That the reported IP differs could be because it changes over time. Do you have a networking expert that could look at the setup? Very strange.

I don’t but I sometimes use a VPN. However I turn it off when I’m using mimolive, and I usually restart before using it so that there isn’t much else running on the system except what I need for the broadcast. So it’s not an issue of the vpn being on when I’m using it; I wonder if there are issues with the vpn software? but it’s strange that it would (seemingly) only affect port 8989, isn’t it?

If you have multiple network interfaces configured, mimoLive can pick the wrong, not active IP address for the server. I had this multiple times with a Mac configured for Ethernet and WLAN and mimoLive picked the IP of the WLAN which was not active but Ethernet was active.

My guess is that we pick the one suggested by MacOS which is the one at the top of the list in the network control panel. (There is a button…)

Not always if I remember correctly, Ethernet is top, second WLAN, but mimoLive picked a non working WLAN IP.

1 Like

The order is set separately. I think an inactive network can still be at the top of the priority list. But of course this behavior is clearly a bug. Not sure if we can fix it in mimoLive, though. Might be an OS bug.

I will check this a soon as I’m back in office. Perhaps I remember wrong!

This sounds like it could be the issue. I’m using Ethernet and that interface is always at the top of the list in the network control panel, with the expected 192.168 address. I just opened and checked mimolive now and it thinks it’s serving at [This confirms your earlier suggestion that the 173 IP was changing]. Ethernet is the only interface with a green dot next to it to indicate that it’s active; the others are red and my VPN interface is yellow. (Looking into the VPN “Advanced” dialog, the IP address starts with 185, not 173.

By the way, and I have no idea if this is related or normal behavior I’ve noticed that sometimes (specifically, if I restart the mimolive remote server from preferences) instead of the computername.local address it suggests a very long address name that I can access from the local machine but cannot from elsewhere. This address ends with my ISP name [] but I can’t find it from another computer and no valid IPv4 address comes up for the hostname if I plug it into an iplookup page. So it’s like there’s a phantom network that only works on my local machine and only comes up for this particular port.

I guess the information is coming from the VPN. If you connect, more than just the network connection is changed. A VPN login might add a proxy server, a DNS server and more. This means that your Mac can figure out the DNS name from the IP and will show this in mimoLive.

Can you check if you can change this in the Network Preference pane, finding the Set Service Order command:

Yes it allows me to change the order of services that way, but it has no effect on the problem. However I noticed that I can sometimes get mimolive remote to work but only while the VPN is ON. It changes the ip access address to - which is still incorrect for my network - but everything works as it should with the VPN ON. If I turn off the VPN after that, mimoLive remote stops working again (and the access address becomes Even with the 10.0 IP address in a browser, I cannot access the mimoLive remote at all unless I’m on the local machine. [Note - when VPN is connected, a browser will work with the computer.local:8989 address but not with the address].

I need to be able to use mimoLive without the VPN connected at all, since I want a direct connection to the internet while doing this. (Strangely this behavior continues even if I set my application-specific VPN preferences for mimoLive to “always bypass VPN”). Is there any way to tell mimoLive Remote to get the IP address directly from MacOS rather than from the VPN? I’m using mimoLive Remote through the LAN, so it shouldn’t be trying to establish the external IP address at all anyway, right?

Any more ideas here? I’m streaming tonight and encountering the same problem. I have been able to “trick” mimolive into using the 10.0 address by turning the VPN on and off, but it makes no difference to the actual behavior of mimolive remote – I simply cannot use it remotely (on my LAN) without the VPN on.

This is definitely very odd. Almost as if you’re running a VPN through another VPN. How is your computer connected to the ISP? You can also check in Network Preferences to see if the VPN has the “Send all traffic over VPN connection” enabled. This should be off.

My computer is connected via ethernet to the modem. And I don’t see anything like that “send all traffic” preference in Network Preferences. My VPN is PIA, and it does not show up in Network Preferences; it is a separate app that I control from the menubar. You can choose which apps will bypass the VPN (and I have put mimolive in the list). But the thing is I’m having the problem when the VPN is disconnected, and even when the VPN software is quit completely.

Isn’t there any way mimolive could query MacOS for the IP address the same way other servers do, like a web server? I’m still confused about why mimolive would get a different answer for this query than other servers I have used, including icecast, webserver, etc.

If your computer is connected to a “modem” and not a “router” this starts to make sense. When you connect to the ISP, your Mac is getting an IP address from your ISP in the 173. range. I guess their software is using a VPN type of setup to get a secure connection. But no other device in your network gets this IP number and they can not connect to that number. Can you ask your ISP to provide you with a router to connect your entire network to the internet? This will make sure that all devices on your network are in the same subnet and can talk to each other.

My bad; I am connected to the router. I have both a modem (directly connected to the wall) and a router which my computer is plugged into. The router is connected to the modem. So that’s not the issue :frowning: