Face Tracking causes nasty distortion left+right

I’d like to use Face Tracking and like the accuracy with which it is working.
But using latest v6.2b3 I’m missing any settings on the fx panel at all.

More than anything I wish to disable the nasty distortion happening as soon as the person comes to close to the left and right edges.

If I may allowed to do another suggestion here; a speed property would be great to adjust the effect to work slower if needed to reduce distractions.

Thank you for your report and your feature suggestions.

You are right, this filter don’t have any options by design. The distortion on the sides are needed to fill in missing image information because the filter don’t reduce the image size and therefor don’t have space around the image to simulate a camera pan.

This is different with the more complex “Follow” layer. It zooms in a bit and therefor has some spare pixels around the image to move the virtual camera to. However it lags the option to adjust the following speed.

Would the Follow layer work for you?

Hi @Achim_Boinx
Thanks for your fast reply and the tip with the “Follow” layer.
I just tested it and the algorythm seems to work fine.

But the Follow layer is not usable for my scenario however, because it does not allow me to crop and position the video somewhere in the screen.
Instead, I’m using a PIP Window with around a dozen different possible positions and sizes (as variants).
Everytime I move around a litte I need to adjust the camera to ensure that I’m still in the respective layer area.

So to me, the “follow functionality” of the “Follow layer” added to the “PIP Window layer” would be my preferred and most desired solution here. Maybe combining these two layers isn’t a big thing because all functionality already work well…? :slight_smile:

Combining two layers of that complexity into one layer is a really hard problem. However you can make it work with the help of the Syphon Sender/Receiver trick:

  • Put the Follow layer at the very bottom of your layer stack. Configure it with your video source.
  • Add a Syphon Sender layer above the Follow layer.
  • The next layers above should somehow cover the Follow layer so it’s not visible anymore in the program out.
  • Add a Syphon Receiver source to your source repository on the left.
  • Use this Syphon Receive Source in your PIP Window layer and you can crop the video here.

I just tested the Syphon Sender/Receiver trick described above.

For me this unfortunately doesn’t work because I already need a Syphon Sender to show parts of the layers on another separate screen.
As soon as I’m adding a second Syphon Sender (at lower position to keep the Follow Layer invisible in Program-Out), I’d expect to get the possibility to select the Syphon Server Name in Syphon Receiver Video Source.
Instead, it keeps receiving the Syphon stream from the most top positioned Syphon Sender.

If it’s too hard to add the Follow Layer functionality to the PIP Window (which would be the easiest solution for users from my POV) then it would be desirable to have the possibility to choose the respective Syphon Server if there are more than one.
Also, this would be necessary if someone wants to use a combination of Follow and PIP Window for more than just one camera (like I do).

If you are running multiple Syphon Sender layers you need to specify a Server Name for each layer individually (Syphon Sender - mimoLive - 5 ). Then each layer is shown as a possible source in the Syphon Receiver source ( Syphon Video Receiver - mimoLive - 5 ).

Ah, now I found the properties where one can select the respective Syphon Server - many thanks!

I tested it again and it (technically speaking) «works».
To me it still can’t be used, as the format of the PIP Window not equals the original one and therefore causes the Follow layer to falsly assume the face is still in the picture.

(large PIP shows original ratio, small one shows result of «Follow-SyphonSender-SyphonReceiver-PIP Window»)

Therefore the Follow layer reacts to late.
Also when testing with different zoom settings, the effect can’t be fine tuned…

You can try to use a second document with square pixel dimensions having the Follow layer and a Syphon Sender layer to produce the cropped video you are after then receive the result in your main document with the Syphon Receiver source.

Sounds good, but unfortunately I can’t get the follow layer to become fullscreen:

Then, I tried with the Placer layer combined with the Facetracking FX.
This let’s me do the cropping but adds the distortion at edges again…

The Follow layer is only showing the complete video in the Preview area like your screenshot is showing. The program out view of that layer should be full screen thought. Isn’t it?

You’re right! Preview and Program out is not the same (contrary to the expectation one may have).
And hey, with this knowing I got it setup and running!
It’s rather bulky to setup, testing and demands to have another document opened but at the end it really works.

Important also, is to set custom resolution for the Syphon Receiver video input in the main show setup.
Otherwise it assumes full resolution (1080p in my case).

At the end: it is possible, but it comes with a complexity in setup and testing.
Many thanks for the help!