crash whenever I want to open the 450d

Dear Boinx,

I bought your software yesterday, for a workshop with kids I should do today. Before that, I had specially bought a second-hand Canon 450D, carefully checking that it was supported by your soft.

Nevertheless, the software keeps crashing whenever I want to open the 450d as the camera.

After a night of sleeping, I think a possible source of the bug is: high sierra. Since I’ve upgraded to high sierra, many softs won’t run correctly… so maybe Istopmotion can’t stand high sierra either?

Here is my computer configuration:
MacBook Pro (13 pouces, mi-2012)
2,5 GHz Intel Core i5
8 Go 1600 MHz DDR3
Intel HD Graphics 4000 1536 Mo

Pleaee, help me! Or refund me!!!

Best regards,

I am deeply sorry about the crashing app! Please can you send me crashlogs in a DM?

You can find recent crashlogs in the “Console” app, select the folder “User Reports” in the right column and send me the listed iStopMotion crashlog files. Thanks!

Hi Achim, thanks for quick feed-back. i’ve sent you the crash-log as mp (it wouldn’t fit as an answer here, too long)

Somebody from the sales dpt gave me a list of things to check, and I think maybe that could be for eos utility automatically controlling the 450d and causing the crash. I will try to uninstall utility.

Oh, I’ve tried that, and it still wouldn’t work, same issue as soon as I choose the 450d… Achim, were you able to have a look at the crashlog file, that I’ve sent you as mp?

Thanks Wayne and Achim for your suggestions, but nothing helped yet, and I am tired… next workshop in ANIMAC next week will be done “old way” with no linetest (and no istopmotion), just with editing software, but I still hope we will find a way before the next kids workshop on monday the 26th… kids are so impatient, they love to see the animation straight away.

@MariePaccou Can you do a last test? Just remove the SD card from the camera and test the capturing in iStopMotion without the memory card installed. To make sure everything gets the chance to initialise correctly switch off the camera and disconnect the USB connection from the Mac while removing the SD card. The cam may require to enable “Release shutter without card” but in my test with the Canon 700D it worked even with this option set to “OFF”.

Hi Achim, I’ve tried. I took off the SD card.
Then it doesn’t crash as soon as I connect the camera, but it keeps “preparing source” for ever. If I cancel “preparing source”, and try to take a picture, it fails.

Hereby a photo of the camera, and the soft, if you see something I forgot.

enter image description here

Bigger size here

hum, bigger size here, sorry:

At least its not crashing anymore which is a big step forward in my opinion. Unfortunately the connection to the camera is a bit fragile. Please can you make sure that no other software is running in the background potentially talking the the camera too. To do so the best way would be to reset the complete setup by restarting the computer and restarting the camera by removing the battery temporarily. First start iStopMotion and create a new project, then connect the camera again.

Hi Achim, there must be something running automatically the EOS, because if I just plug the camera to the computer, without opening any soft, the camera says “busy”. Yet, I’ve erased Canon utilities from the macbook, verified that “no application” was allowed in Imagecapture. What else can it be? Dragonframe, Photobooth? (I wouldn’t like to erase Dragonframe from my computer, it’s costy and useful). Where can one find the sneaky soft that monopolize my camera?