Crash at opening

This morning my Fotomagico don’t open. “Unexpected”.
Any information about this crash.

I have the same problem. I send a note to Boinx and wait for a response…
I tried to restore the app via Timemachine and downloaded the app from internet, but nothing helps.
Process: FotoMagico 5 [640]
Path: /Applications/FotoMagico 5
Identifier: com.boinx.FotoMagico5
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: FotoMagico 5 [640]
User ID: 501

Date/Time: 2017-02-23 09:00:19.618 +0100
OS Version: Mac OS X 10.12.3 (16D32)
Report Version: 12
Anonymous UUID: 7040C768-7CF2-A9EF-C6D2-F22797A8E8D0

Time Awake Since Boot: 82 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):
mapped file 000000010569e000-00000001058a3000 [ 2068K] r-x/rwx SM=COW

Thread 0 Crashed:
0 dyld 0x0000000114a08000 _dyld_start + 0
1 ??? 0x0000000000000001 0 + 1

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007fff5a561c50
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x0000000114a08000 rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

Binary Images:
0x114a07000 - 0x114a44267 dyld (421.2) <947FC440-80F9-32F7-A773-6FC418FE1AB7> /usr/lib/dyld

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 104
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=336K resident=0K(0%) swapped_out_or_unallocated=336K(100%)
Writable regions: Total=8404K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8404K(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Stack 8192K 2
__DATA 220K 3
__TEXT 248K 2
mapped file 2900K 4
shared memory 8K 3
=========== ======= =======
TOTAL 67.4M 12

Model: MacBookPro13,3, BootROM MBP133.0226.B11, 4 processors, Intel Core i7, 2,9 GHz, 16 GB, SMC 2.38f6
Graphics: kHW_IntelHDGraphics530Item, Intel HD Graphics 530, Built-In
Graphics: kHW_AMDRadeonPro460Item, AMD Radeon Pro 460, PCIe, 4096 MB
Memory Module: BANK 0/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
Memory Module: BANK 1/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x15A), Broadcom BCM43xx 1.0 (
Bluetooth: Version 5.0.3f1, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
USB Device: ASM107x
USB Device: ASM107x
USB Device: P’9223 Mobile Drive
USB Device: Porsche Mobile for Mac
USB Device: P9237 Desktop
USB Device: iBridge
Thunderbolt Bus: MacBook Pro, Apple Inc., 15.8
Thunderbolt Bus: MacBook Pro, Apple Inc., 15.8

I’m sorry that you experience this issue. We are working on it.

Meanwhile, please download version 5.2.3 from

For details, please follow this thread:

I’ve recorded the issue and you can see it at

@shinstudio Thank you for taking the time to make a recording and send it in. We are aware of the issue and know what needs to be done to fix it. Apple has advised to wait for their fix. Meanwhile you can download version 5.2.3 which works.

I know Oliver has addressed the issue, above, but I wanted to chime in that I, too, had problems this morning. After spending over an hour deleting prefs files, re-installing, and double-checking everything, and ALMOST going through a complete system backup restore – I finally got on the forums to find I wasn’t the only person experiencing the glitch!! Strange to see OTHERS having the same problem at the same time. It seemed like it was just something “independent” and totally related to MY system. Now I see it’s a global issue.

Hope the Boinx guys can this fixed soon :slight_smile: They’re pretty good about that! :wink:

Yeah – 5.4 is working! Thanks, guys!!

will not open for me as well.

@Newcastle Have you tried Version 5.4?

We had the same problem with Fotomagico as well as another program. THe certificates expired on Tuesday. We were running 5.3 (we had updated to it just in December!), didn’t realize there was a v.5.4. We were eventually able to download the 5.4 by making a fake certificate. All is well now thqt we were able to download the installer for the 5.4

@Mary_T How did you make a fake certificate?

Basically used the same certificate for 5.3 but changed the expiration date. We still needed to supply the license name and number. But, we were able to update directly from our old install.
We also had another Apple certificate that that expired on the same day as well. I’m currently working off a PC and not near the mac files. I’ll look for the text file.

sorry, fixed.