CPU Usage spike

Hi, I recently noticed (during live streams) that after just over 1hr or 1.5hr, the CPU usage starts spiking… causing the machine to be unstable.

Is there a way to only use the HARDWARE GPU? My specs are solid enough to should run MimoLive with ease.

I only use the machine during the stream for MimoLive and VirtualDJ (Nothing else)

Please see below my specs.

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro16,1
Processor Name: 8-Core Intel Core i9
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache: 16 MB
Hyper-Threading Technology: Enabled
Memory: 64 GB
System Firmware Version: 1554. (iBridge: 18.16.14663.0.0,0)

AMD Radeon Pro 5500M:

Chipset Model: AMD Radeon Pro 5500M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 8 GB
Vendor: AMD (0x1002)
Device ID: 0x7340
Revision ID: 0x0040
ROM Revision: 113-D3220E-190
VBIOS Version: 113-D32206U1-019
Option ROM Version: 113-D32206U1-019
EFI Driver Version: 01.A1.190
Automatic Graphics Switching: Supported
gMux Version: 5.0.0
Metal Family: Supported, Metal GPUFamily macOS 2

Intel UHD Graphics 630:

Chipset Model: Intel UHD Graphics 630
Type: GPU
Bus: Built-In
VRAM (Dynamic, Max): 1536 MB
Vendor: Intel
Device ID: 0x3e9b
Revision ID: 0x0002
Automatic Graphics Switching: Supported
gMux Version: 5.0.0
Metal Family: Supported, Metal GPUFamily macOS 2
Colour LCD:
Display Type: Built-In Retina LCD
Resolution: 3072x1920 Retina
Framebuffer Depth: 24-Bit Colour (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Automatically Adjust Brightness: Yes
Connection Type: Internal

Please turn on mimoLive’s Debug Mode, and select your particular device for rendering. See online documentation, how to turn it on.

operative system? Big Sur?

Yes it’s Big Sur… any problem with that? :slight_smile:

I would say yes

Any reasons regarding not using Big Sur as it’s been around for quiet some time.


For anyone who has experienced the same issue as above… I managed to find a work-around that is fairly solid…

To avoid almost any CPU usage no matter how heavy is your setup… ( I currently have 2 GoPros 1 MackBook Pro webcam and a full HD external cam, all running at the same time during the entire stream session and countless layers and effects including multiple external audio sources) simply minimize the application while streaming.

In my case, I do use StreamDeck which has made the process even smoother as I can control MimoLive fully from my StreamDeck but this (minimizing the software) has definitely solved the CPU usage spike by 90%… that 10% or less use surely what’s required to run it which is fair enough.

I think the main culprit isn’t even MimoLive but the WindowServer which is a required MAC OS app that draws the front-end of any app… with the multiple cameras on and the keepalive settings etc, surely this requires strong resources.

Following this setup/steps… I managed to do a Livestream while mixing music using software on the same MBP that I’m using to stream for over 3 hours while the CPU usage never went above 14%… pretty good hein!!! :wink:

Can you explain what you did exactly? I’m having incredible CPU spikes (from like 70% to like 220%), especially when I use a video slide show source or a browser window source. Minimizing mimoLive using the yellow button on the app does nothing to the CPU spike; are you doing something else?

Could you also close the output video preview… like mentioned above, I use StreamDeck to control scenes. I think it’s worth closing the video output preview (can also be minimised within the mimolive app) and then minimise the mimolive app itself should solve your issues.

I never used slideshow or browser capture on mimolive to be fair, these layers would surely use lot of ressources especially the screen capture on the browser.

Good luck.

I discovered Cpu spikes using windows capture mainly appears when you capture area is bigger than document size.
Simply resize down the browser windows and the cpu usage will down a lot

I did exactly as described - first close the output preview window and then minimize the app; this has no effect on the CPU usage.

This makes sense. Unfortunately if I resize the browser window I can no longer see the image (and I can’t control resolution in the external window). But I might make the entire document bigger and see if that helps.

Post here the site you need to show

it’s a URL for an overlay via streamelements; there’s very little actual stuff to render most of the time, which makes it stranger that it’s hitting the CPU so hard … StreamElements

Edit - I should add that some of the content is dynamically generated, so the black box off to the side will fill with chat, and some emojis will be drawn and bounce around the screen. But I’m getting the CPU hit even when there is no dynamic content being generated.

Transparency is also something. You‘re rendering transparency frame by frame, maybe in a too high resolution too. See other post for suggestions.

Can you help me understand that better? Is there a way to avoid “rendering transparency frame by frame”?

I’ve tried converting the whole project to 1080p but that seems to make things worse. mimoLive crashes constantly now.

See other post for suggestions :slight_smile: Web Browser Capture

1 Like