Can someone please give me a definitive answer...DSLR connectivity?

I most probably share the frustrations of a lot of ISM users when trying to get the software to work with a DSLR. I have tried all of the advice on this forum but none of the answers from Boinx staff seem to resolve the issue I (and a lot of other users) am having with connectivity.

I am using a Canon 550D / T2i on a MacBook Pro running Mac OS 10.7.5 with iStopMotion 3.6. I have set my Image Capture settings so that no action is taken when my camera is connected. My camera is set in full manual mode with JPEG selected. I know that this setup is correct as every now and again the software and camera connect correctly and I can animate without any problems. The vast majority of the time however, I launch the software and when I come to take the first frame, the camera shutter triggers but I get the ‘Could not connect to digital still camera. The operation timed out’. I have even tried dropping the JPEG settings to medium and the problem still persists.

Does anyone have a solution to the unreliable and inconsistent way in which ISM connects with Canon DSLRs? I am trying to run a business delivering stop-motion animation in schools and I need this software to be reliable and dependable EVERY time! Can anyone from Boinx explain to me why the software works one minute and then fails to work the next? Your urgent help would be greatly appreciated.

Hi,

since you say the shutter is triggered the error can only happen in the process of transferring the image. Please bear with me, since I have to jump from possibility to possibility with you here to figure out why it doesn’t work for you. We have a 550d here and it just works.

So here comes the list of things I’d ask you to try:

  1. Is the canon utility running at the same time as iStopMotion? If so, please quit it as it may interfere with the communication.
  2. Just for testing, can you please set the camera to Raw/JPEG and retry.
  3. Since it is triggering, I don’t think there is an issue with the lens, but can you please double check if the lens is in manual mode as well?
  4. How is the camera connected? Directly? through a hub? If possible choose the other way. Or choose another USB port.
  5. What Firmware is your 550d running on?
  6. are you operating the camera any other way while using iStopMotion?

Hi Bastian, many thanks for your reply. As mentioned in my previous email, whenever I try to use iStopMotion 3.6, the software either fails to progress past the black screen with the text ‘This device supports live preview’ (please see screen shot attached) or if it does progress past this point, when I try to capture an image, I get the ‘Could not connect to digital still camera. The operation timed out’ error message (please see screen shot attached). If I restart iStopMotion a few times or shut down and restart the computer, I am sometimes able to get the software to work but this is clearly an unacceptable situation and not something I would expect from Boinx (whom I have supported for many years now and recommend widely to the schools I work in).

In answer to your list of points above…

  1. I have already stopped the Canon utility from launching when my Canon DSLR is connected.
  2. I’ve tried setting the camera to RAW/JPEG and the software is still failing.
  3. The lens is definitely set to Manual.
  4. I connect my DSLR through USB directly into my Mac. I have tried both USB ports on my computer as well as additional cables and the software is still failing.
  5. Firmware Ver. 1.0.9
  6. No.

Yesterday I reset my version of iStopMotion by deleting the Library preference files (as recommended by a member of Boinx staff) which unfortunately did not solve the problem. I also hired an additional Canon 550D to check whether the problem was with my camera but the software continued to fail.

I am now getting to the point of desperation and any further help you could offer would be greatly appreciated.

Hi!

I also have exactly the same problem, and it is also getting me to the point of desperation!

I’m using a Canon 7D with an iMac. I tried everything. Reseting the computer, reseting the camera, turning the camera on first, launching iStopMotion first, changing USB ports… Sometimes it works, sometimes it doesn’t.

This is the first time I’m using this software and I bought it because it guaranteed that it worked with Canon DSLRs. It’s proving to be disappointing… Please, can anyone help?

EDIT False alarm, it didn’t really solve the problem yet…

Ok, I called the tech support and the problem is solved! (At least it never happened again.)

A lot of steps had to be followed, I’ll try to list them as much as I can remember them, but I think only the last step really solved it:

  • The camera should be on manual
  • The lens should be on manual focus and image stabiliser should be disabled
  • If using ac power remove the battery, if using a battery have it fully charged
  • Remove the SD/CF card

From the camera menu:

  • Auto lighting optimiser should be disabled
  • Release shutter without card should be enabled
  • Peripheral illumination correction should be enabled
  • Live view shutter should be enabled and no face detection should be enabled
  • Auto power off and auto rotate should be disabled

Software:

  • Close Canon Utility
  • In image capture, on the bottom left, set “connecting this camera opens” to “no application”

That’s it, I turned the camera on, launched iStopMotion (in this order) and it works!

Let me just close with a note about how great the tech support works, and that you should call if anything goes wrong! I called using Skype and payed next to nothing.

I’m experiencing the same issues as others here on this forum.
ISM 3.6 (latest rev) Mac OSX 10.9.3 (fully updated) Canon EOS 700D
I have followed the directions as listed by xassbit above but I haven’t been able capture a single frame, I am able to get a live view, however, when I try to calibrate the Live view I get “The Operation couldn’t be completed. (ISMCaptureSourceError error 9006.)” dialog box. If I try to then to capture an image I get “Could not connect t digital still camera. the operation times out.” dialog box. Both screenshots are attached,
I’m at loss at what to do next and after spending close to AU$1000 on a new camera and AC adapter on a supposedly “supported camera”, I’m naturally extremely disappointed.
Ideas anyone please?

Update: I chatted via e-mail with the tech support and we concluded that uninstalling the Canon Utility program would solve it, which it did up until today, where the same problem started all over again…

I have the same issue, but posted in another thread. I tried the above official solution with my 60D - does not work, still times out. I have used ism for a long time, I run anim workshops every year for orphans and other kids in Eastern Europe, ism has the best gui for that but I now have to ditch it and go for Dragonframe which works but is not so elegant, or just use a webcam or an old firewire camcorder… Boinx you have annoyed me, announcing dslr functionality then not delivering!

I finally got ISM to work with my Canon EOS 700D. I followed all the instruction in this thread with no luck. I noticed whilst fiddling with the ISO settings on the camera that they were not being updated in the source panel within ISM. These are the steps I use to get ISM to work most of the time.

  1. Turn off your camera and launch ISM.

  2. Once ISM has launched and you have selected your file name, location and resolution, turn on your camera and select it from the source list.

  3. Click on the live view button beside the Calibrate button. The Calibrate button doesn’t do anything on my setup.

  4. If the Live View doesn’t appear in the preview window, choose None form the source and then select your camera again. You should now see your Live View.

  5. If ISM fails to capture your Live View image and brings up the error about “… The operation timed out.” Select None from the source again and turn off your camera.

6.Turn your camera back on and select it from the source once again. You should notice that changing the ISO settings on the camera are now automatically updated in the source window of ISM and capturing live images is now possible.

  1. Repeat Step 6 until iSM and your camera start talking too each other.

Hope this helps others and Boinx to fix iStopmotion.

Is this likely to be an ongoing and BIG problem ?
I am just about to undertake a stop-motion project for a client of mine and iStopmotion was top of my list as the software to use. I shall be linking my Nikon D800 to a MacBook Air.
I don’t want to start this complicated project and find that the software falls over.
I’m not sure the project is really worth the investment of money (but mostly time in learning) for Dragonframe.
Recommendations please ?

I have followed all these instructions to no avail. This needs to be resolved. I have encountered the same problem with both the Canon 7D and now the 60D.