Audio delay on live output

We had great success using our 2011 iMac with BoinxTV that our school upgraded to a 2012 Mac Pro. Since the move, we have noticed a major lag (1-2) seconds between our video and audio. The audio trails the video and it looks odd to our viewers. Right now, mics are fed into the our minidv camera and both audio and video are fed via firewire together to the Mac Pro. This set up worked on the iMac. Is there a way to correct the audio delay and have it sync up with the video? It really becomes apparent when we click option-arrow to to begin live output to our closed circuit TV system.

I am having a similar issue. We are using a 2012 iMac. Audio and video are coming into a ADVC110 analog to digital converter and then into the computer. The lag is very, very bad and it does look terrible to our viewers.

The big delays may come from an overload of the GPU or CPU. Can you please check if the CPU is performing well (with the “Activity Monitor” Application by Apple) and that the GPU workload is ok (the percentage in the top display of the document window on the right schould be well under 100%). Also there shouldn’t be a red “frame” icon below the percentage. This would indicate that BoinxTV has to drop frames because it can’t render them fast enough.

However for short audio/video delays you can setup a delay in the preferences of BoinxTV (select the Devices-tab and setup a delay for your audio input).

Audio was already delayed so we don’t want to delay it further. It was about 2 seconds behind video. We played around with it and the only work around we had success with was changing the output sound setting then changing back to what we wanted. Surprisingly, that seemed to work. Thanks for the input though!

Can you please be a little more specific on how to set up the delay? I am seeing a red frame like you describe, so we need to adjust the delay as you said.

@burlesot: If you are seeing the red frame, then you have to reduce the GPU load by disabling layers. Delaying the audio will only help for the symptom but not for the root of the problem. However: The audio source delay has to be entered in the BoinxTV preferences, “Device” list. Select the audio hardware you are using and setup a delay in the inspector on the right side.

@BETV: This may be caused by the use of different audio sample rates. Please make sure that you have setup your sound input (with the “Audio MIDI Setup” application) and any movie files used in the BoinxTV document, to the same kHz value.