Alerts disturbing presentation?

Is it possible that alerts or dialogs e.g. from Calendar or Little Snitch disturb a presentation?

While FotoMagico requests to run on the topmost layer, we can’t make 100% sure nothing can pop over it. To make sure you don’t get any OS X Messages you can switch to “do not disturb” mode by clicking the notifications icon on the top right:

Then make sure you are in “Notifications”, scroll up a bit and enable “Do not disturb”:

Thank you for your detailed answer!