›

High Sierra or Mojave?

Just purchased MimoLive for our church. We have an imac that's running High Sierra to use for the software. Should we use High Sierra or upgrade to Mojave be fore we install the software?

Comments

  • @AL210 Thank you for using mimoLive! If you can, I would love to get some photos for a use case story...

    mimoLive is supported for macOS 10.11 and newer. Personally, I would upgrade to Mojave, because it is the latest and greatest! There are no known issues with Mojave in mimoLive.

Sign In or Register to comment.