›

News Crawl. How to make it start from beginning?

No amount of starting, stopping, making the News Crawl live, making it unlive, or checking the "restart on live" button appears to make the News Crawl restart from the first item (working from a Text list of items). Am I just missing something?

Comments

    1. Please can you tell me which version of mimoLive you are using?

    2. Also at the top of the layer parameter column it shows you which version of the layer itself, e.g. "News Crawl (v4.7)", is this the version that you are using too?

    3. Please can you provide a sample document which demonstrate the issue?

  • edited December 2018

    Version 4.5 (26739)
    News Crawl (v4.7)

    I originally was working with an older version just to build a news crawl to send via NDI to another streaming suite. So I pulled down the latest version just to see if it was resolved. I even generated a whole new News Crawl (my crawl is a list of the top-50 high school football recruits) using the newer version (rather than work with the one created in version 2.x).

    It starts at the beginning when I open the document. But there appears to be no way to get it to start from the beginning when I go live with it. It just starts wherever.

    Checking the "restart on live" option makes no difference, and seems to have no noticeable effect on anything.

    I appear to be getting the same result with the demo rss feed from https://boinx.com/blog/rss/. Only worse. Those don't even load in any order. They just seem random when compared to the contents of the actual rss feed.

    I tested the 'random' theory by building an xml/rss file of what I've been pasting into the Text field of the Crawl. Sure enough, the 50 players I'm putting in the Crawl come in randomly, not in order. (I guess I could go back and add fake time/data metadata to see if that orders them).

    Interestingly, if, after the RSS test, I switch BACK to using the information from the Text dialog, it STILL picks up somewhere in the middle of the text. Not at the beginning. Almost like it goes back to where it would have been anyway had I not changed the source.

    I can send you my document, and the rss, but, really, it's not hard to reproduce. There is no point at which the crawl starts from the beginning except for the initial opening of the document.

  • @tgromak Thank you for taking the time for reporting this. You're right, it is easy to reproduce. However, it might be more a conceptual error than a bug. I'll try to get to the bottom of this.

  • @tgromak @Richard1 Unfortunately this is really a bug which can't be workaround. The next mimoLive beta 4.6b2 will include the fix for this issue. Sorry for the inconvenience!

Sign In or Register to comment.