›

"This output destination has performance issues"

edited December 2018 in mimoLive

I get this message on several occasions, at different venues. Every time I have excellent uplink (tested and ranging from about 50 Mbit/s to over 1 Gbit/s). I have previously set the 1080p25 bandwidth to 5000 Kbit/s, i.e increased from the default 2,5 Mbit/s. When I tested today, I stopped the show and decreased back to the default 2500 Kbit/s, and then it worked well. So my question is, should I simply stay with the default setting and not increase the maximum bandwidth? Does this setting keep the quality in full HD? I don't think there is a performance issue with the ISP itself, but could it simply be my CDN? Can I test my CDN provider somehow? (I have fresh screen grabs I can send, if it helps)

Comments

  • @Erik Thanks for using mimoLive. The problem is that the "last mile" network connection doesn't translate directly to the available ingest speed at your CDN. Three factors come into play: the bandwidth allowed for ingest, the utilisation of their connection and the location of the ingest point with regarts to how the data travels from your location to the ingest server. You could ask your CDN provider if there is a better located ingest server and what data rate they support/recommend.

    We've chosen 2.5 Mbps as the default because it seems to be a reasonable compromise. Of course, H.264 is a lossy compressor, so lower bit rate means less quality. If you consider that Facebook, YouTube & Co. transcode the video to even lower bit rates, ingesting at a higher bit rates doesn't make that much sense and doesn't give you significant better quality.

  • Posting here as well as to the "Very high "Current Upload" in Stream Status" post. (related issues)

    New theory: The spikes generated from the hardware encoder (about +15 seconds of 50-80 Mbit/s) causes packet losses, thus sets mimoLive to adjust the data rate to lower than the preferred setting. Other streaming forums reports similar problems. It would be nice if you guys look inte this as well. https://telestreamforum.forumbee.com/t/36dzql/wirecast-bug-bitrate-spike-apple-encoding-00618449

Sign In or Register to comment.