›

Playback speed of ProRes 4444 file

edited October 21 in mimoLive

I've created an animation in Motion that I want to use under a lower third. I basically followed this tutorial (except that I use Motion).

The exported ProRes 4444 file does not always play reliably though. When mimoLive is started fresh it's all fine. But after a while the playback of the file seems to slow down. Causing the lower third animation to get out of sync. Also when I play the file in a simple Placer layer it also slows down. Also it doesn't start immediately when I put the layer live. It first shows a few frames of what currently is shown in the preview windows before it restarts from frame 0. If it restarts at all.

I'm using a 2016 MBP so I think the hardware should not really be a problem (I hope). The render performance meter does not show any issues or delays.

The source file as generated by Motion can be found here.
A video demonstrating the problem can be found here. The first two animations are fine. The last part of the video shows that the animation video plays out of sync with the text animation.

Am I doing anything wrong?

Comments

  • @eMilty Thank you for using mimoLive. I'm sorry to hear about the troubles.

    It's great that you shared a demo video and the ProRes file. Could you also please let us know:

    1) Which version of mimoLive you are using?
    2) Which version of macOS you are using?

    It would also be great if you could send the mimoLive document that shows this behaviour to support@boinx.com if you do not want to post it here with WeTransfer.

    We will get to the bottom of this!

  • @eMilty One thing I noticed is that the ProRes file is rendered at 60fps. Are you also recording 60fps with mimoLive?

  • I've created a very simple document with just a camera and a lower third that also has this problem. It can be downloaded here. To speed up the chance of the problem occurring I generally change the duration time of the transition, e.g. from 0.5 seconds to 1.5 seconds, show the lower third and later change it back.

    I'm using mimoLive 4.4.1 on macOS 10.13.6,

  • @eMilty Thanks for sharing your document. We could identify a problem which arise in the upcoming beta 4.5b1 however we didn't fix it in this beta. It will be fixed in beta 2.

    In the mean while: Please can you increase your Text Duration parameter in the Lower Third from 6 secs to 7 secs and make sure that the Lower Third is not selected in the layer stack when setting it to live? Does this prevent the issue from happening?

  • @eMilty Also I realised that you rendered your Lower Third background movie as a full frame 1920x1080 pixels video having a lot of transparency pixels at the top. You can save a lot of CPU cycles if you just render 250 pixels in height containing the lower third animation from the bottom. This may not save a lot in file size but a lot of memory that needs to be pushed from CPU RAM to the graphics card RAM.

  • Thanks for that tip about the lower 3rd frame size, Achim!

  • @"Achim (Boinx)" Yes, I realized that later that I don't need to have it at the full resolution. I will change that. So if I understand you correctly, as long as I don't let it show in preview I should not have any playback speed issues?

    By the way, is there a way for a placer to play a video file and at the end of it freeze at the last frame and hold that frame until the layer is taken offline?

  • @eMilty
    1) We released a beta version 4.5b2 which should resolve this issue. Please can you download the version and give feedback if it works for you? Thanks!

    https://boinx.com/connect/mimolive/versionhistory/4.5b2

    2) Stopping a movie with the last frame is an option you need to set in the movie source itself. The "Mode" option is "Playback once and freeze". Please refer to https://docs.mimo.live/docs/media-file#section-playback-mode to learn more about it.

Sign In or Register to comment.