Questions about JSON Importer

Hi everyone, it's been a while !

I'm working on some layers, often using json, but lot of time when I want to update the Json Importer I've this error :
["JSON Importer" @ "Macro Patch"] > JSON Import error: Error Domain=NSCocoaErrorDomain Code=3840 "JSON text did not start with array or object and option to allow fragments not set." UserInfo={NSDebugDescription=JSON text did not start with array or object and option to allow fragments not set.}

Even if my json start with a "{" ... Do you know why ?

Oh and I've imported a very simple custom layer in mimoLive, that import Json data, and when testing alone, it was using a lot of cpu, so I decided to open in QC, and saw in debug mode that the Json Patch is always running, even if the data are fully loaded.

I'm working on a lua script like you to control that but it didn't work actually, may be it cool be good to make a new version of the json patches ?

Have a nice day !

Comments

  • @DaBv Thanks for using mimoLive. We're excited to hear that you're creating your own layers. May we ask what kind of layers these are? Also, if you send us a complete JSON file that produces this error either here or via DM, we can try to see if we can spot anything. We use JSON in various layers, for example the recently published "Music Track Layer" available from the More Layers page.

  • Hi @"Oliver (Boinx)" , I come back to QC, using the same Json, but apparently the error didn't appear... strange

    However, I've changed a value in my json, and when I update the Json importer, nothing append, I mean, all the values stay the same !

    I investigate to find why (it's look like a cache in the json patch :/ )

Sign In or Register to comment.