Audio Delay makes mimo reporter un usable

So this video pretty much describes the problem... how is everyone dealing with it? do i just need to turn my monitor down? the echo is making my brain crazy!!!

video of issue

Thanks!

  • Cordes

Comments

  • @"Cordes Owen" From watching your video this does not seem to be an issue with mimoLive Reporter. Am I understanding your setup correctly in that you hooked up a mic to your Mac via the ATEM Switcher and selected it as the audio device of a source in mimoLive for the Mac? The issue then is that the audio output of mimoLive is delayed. If that's the case could you please check the following:

    • Is the mic audio input into mimoLive delayed as well? You should be able to find out by checking the level meter on the source (on the very left) where you selected the mic as audio device.
    • Have you set a delay for the audio device in the source? In the source where you selected the mic as audio device input click the cogwheel button at the right of the Audio Device popup menu to display the device settings where you will find a Delay option at the bottom of the popup.
    • Is all audio output from mimoLive delayed? Drag a video file to the layer stack and activate the newly created layer to see if it its audio is delayed as well.
  • The reason this is a reporter issue is that it is only completely necessary to monitor via mimolive when you are using reporter. so you can have a bi-directional audio communication. Otherwise you can monitor from your audio board (which is instantaneous) and not worry about monitoring the audio from your other media sources. Does that make sense? It appears that there is processing/compression etc happening inside of mimolive that is causing there to be a delay with the audio monitoring. I have two systems that we have attempted to use mimo live with. One is the full black magic system and another is a roland switch and yamaha sound board with usb interface. in both cases the audio has zero delay from live to monitor in the board but once processed through the mimo live software we experience small delay which is basically a echo from my spoken voice vs. what is heard in the ears from monitoring. this is a major problem for broadcasting. You need to find a way to get this audio to process through the system faster.

    You can see from my video that the audio out of the switch is instantaneous. I tap the mic with my finger and then you see the swith levels immediately move. a split second later you see the mimo monitor levels move.

    No there are no delays configured.

    No the switches work perfectly and there is no delay.

    No the monitoring of the media video is not delayed.

  • @"Cordes Owen" You could try reducing mimoLive's audio buffer size. In the app menu go to mimoLive > Preferences and in the General tab select 64 samples from the Audio Buffer Size popup menu. This should make a notable difference although in your video the audio latency seems to be around 250 ms which is a lot to begin with. On my test system using an older FireWire audio interface with 64 samples the result feels pretty instantaneous.

    Could you please check against other audio software on your system, for example Garage Band, using the same audio device driver that this issue is limited to mimoLive?

    If you are worried about additional processing in mimoLive you can also switch off the Dynamics checkbox in the source. Apart from the optional device audio delay and the main mixing stage there is no additional processing in the signal path.

    As you suggested in your initial post people tend to turn down the monitor level of their own mic altogether and monitor through their hardware instead. In a mimoCall you can achieve this by turning down your mic only in the monitor mix that you send out to the studio. See the manual:
    - https://docs.mimo.live/docs/monitoring-audio
    - https://docs.mimo.live/docs/monitor-mix-configuration

Sign In or Register to comment.